Re: [eclipse-clp-users] Problem: OutOfProcessEclipse and Java

From: Joachim Schimpf (Independent Contractor) <jschimpf_at_...5...>
Date: Fri, 30 May 2008 15:25:40 +0100
Martin Wegner wrote:
> Hello,
> 
> sorry to say that, but when I run the code I posted before under linux I 
> got this error message :(
> 
> "Exception in thread "main" java.lang.NumberFormatException: null
>         at java.lang.Integer.parseInt(Integer.java:415)
>         at java.lang.Integer.parseInt(Integer.java:497)
>         at 
> com.parctechnologies.eclipse.OutOfProcessEclipse.<init>(OutOfProcessEclipse.java:82)
>         at eclipse.main(eclipse.java:18)"
> 
> Greetings!
> 
> Martin
> 
> Problem example code:
> 
> import java.io.*;
> import com.parctechnologies.eclipse.*;
> public class eclipse {
>    public static void main(String[] args) {
>        OutOfProcessEclipse eclipse;
>        EclipseEngineOptions options = new EclipseEngineOptions(new 
> File(""));
>        try {
>            eclipse = new OutOfProcessEclipse(options);
>        }
>        catch(IOException e) {
>            System.err.println("Error: " + e.toString());
>            System.err.println("Error: " + e.getMessage());
>        }
>        catch(EclipseException e) {
>            System.err.println("Error: " + e.toString());
>            System.err.println("Error: " + e.getMessage());
>        }
>    }
> }


When using OutOfProcessEclipse, you need to:

- either invoke RUNME to create a bin/x86_64_linux/eclipse executable

- or include lib/x86_64_linux in LD_LIBRARY_PATH when running your code:

     % javac -classpath lib/eclipse.jar eclipse.java
     % LD_LIBRARY_PATH=lib/x86_64_linux:$LD_LIBRARY_PATH java
	-classpath lib/eclipse.jar:. eclipse


-- Joachim
Received on Fri May 30 2008 - 07:25:59 CEST

This archive was generated by hypermail 2.2.0 : Mon Jul 09 2018 - 02:05:29 CEST