Re: [eclipse-users] Eclipse on Macosx 10.4

From: Kish Shen <kisshen_at_...5...>
Date: Mon, 18 Dec 2006 00:05:06 +0000
Hi Philippe,

Philippe de Rochambeau wrote:
> Thanks for the information, Joachim.
>
> eclipse, jeclipse, and tkeclipse all run now.
>
> Here's the contents of my /Applications/eclipse/lib/ppc_macosx/lib/ 
> SITE_PARAMS file, for those who might be interested.
>
> Please note that daVinci is not installed on my machine and neither  
> are tcl and tk, and that does not seem to prevent [tk]eclipse from  
> working.
>   
I am not quite sure how tkeclipse can run without Tcl/Tk installed. Do 
you get a tkeclipse window when you run tkeclipse? If you do, you must 
have Tcl/Tk installed somewhere. We don't include Tcl/Tk in our 
distribution, and your TCL_LIBRARY and TK_LIBRARY seems to point to 
where ECLiPSe puts Tcl/Tk if you are not using a standard system Tcl/Tk. 
What is in the directory
/Applications/eclipse/tcltk/ppc_macosx/?

Cheers,

Kish



> Best regards,
>
> Philippe
>
>
> ECLIPSEDIR='/Applications/eclipse'
> EXE_DIR='/Applications/eclipse/bin/ppc_macosx'
> SIMPLE="y"
> WANT_MEGALOG="n"
> WANT_PARALLELISM="n"
> WANT_TCL_WM="y"
> WANT_MPS="n"
> REBUILD_DOCS="n"
> TCL_LIBRARY='/Applications/eclipse/tcltk/lib/tcl8.4'
> TK_LIBRARY='/Applications/eclipse/tcltk/lib/tk8.4'
> DAVINCIHOME='$ECLIPSEDIR/daVinci/ppc_macosx'
> TCL_ARCH_LIBRARY='/Applications/eclipse/tcltk/ppc_macosx/lib'
> WISH_DIRECTORY='/usr/bin'
> XWISH_DIRECTORY='/Applications/eclipse/tcltk/ppc_macosx/bin'
> TCL_VERSION='4'
> TCL_FRAMEWORK='/System/Library/Frameworks'
> X_LIBRARIES='@x_libraries@'
> USER_OBJECTS=''
> JRE_HOME='/usr/'
>
>
>
> On 16 déc. 06, at 21:17, Joachim Schimpf wrote:
>
>   
>> Philippe de Rochambeau wrote:
>>     
>>> Hello,
>>> has anyone managed to successfully build Eclipse on Macosx 10.4?
>>>       
>> The SourceForge site http://sourceforge.net/projects/eclipse-clp
>> has binaries for ECLiPSe 5.10#39, built on Macosx 10.2.  See also
>> http://sourceforge.net/forum/forum.php? 
>> thread_id=1615796&forum_id=613916
>>
>> Actually, since at the moment we don't have any Macs of our own,
>> it would be ideal if someone else could volunteer to look after
>> the MacOS builds.  Anyone?
>>
>>
>>     
>>> The INSTALL file says should set the ECLIPSETHIRDPARTY environment  
>>> variable to /vol/Eclipse/thirdparty. However, there is no  
>>> directory called thirdparty in the source directory. Furthermore,  
>>> apart from gmp, none of the required third-party components are  
>>> available from either  darwinports.opendarwin.org or fink
>>>       
>> We'll try to improve the documentation on that.  I've put
>> a recent version of the build guide on the web site
>> http://eclipse.crosscoreop.com/reports/SetupGuideV2.pdf
>>
>>
>> - Joachim
>>
>>     
>
>
> _______________________________________________
> ECLiPSe-Users mailing list
> ECLiPSe-Users@...2...
> http://www.crosscoreop.com/mailman/listinfo/eclipse-users
>   
Received on Mon Dec 18 2006 - 00:05:15 CET

This archive was generated by hypermail 2.2.0 : Mon Jul 09 2018 - 02:05:29 CEST