Re: [eclipse-clp-users] Using Eclipse with Visual Studio 2005 or looking for eclipse 5.8

From: Joachim Schimpf <jschimpf_at_...311...>
Date: Thu, 23 Feb 2012 03:29:25 +0100
Christian Giffhorn wrote:
> Hello everybody,
> 
> i like to integrate some logical planning into an existing Visual
> Studio project, but i have trouble to embed eclipse into an MFC
> enviroment. The errors happen already before compilation of my code,
> which is still very basic on the level of the examples.
> 
> Calling eclipseclass.h or mainly the included eclipse_cc.hh, causes
> around 100 errors then. I believe since it is optimized for a gcc
> compiler, but i was quite sure to read about Visual Studio projects
> existing in eclipse before i start to write the prolog code(using a
> golog interpreter basing on eclipse).  Maybe someone know a solution
> for it?

Hi Christian,

You are right, eclipse_cc.h contains gcc-specific stuff and cannot
be used as is.  I'll fix this for release 6.1.

There is an easy solution though, I've written up instructions at
http://eclipseclp.org/wiki/Examples/UsingECLiPSeWithVisualC

Let me know if that works for you,
-- Joachim
Received on Thu Feb 23 2012 - 02:29:46 CET

This archive was generated by hypermail 2.2.0 : Mon Jul 09 2018 - 02:05:29 CEST