Re: [eclipse-users] tkeclipse doesn't run

From: Kish Shen <kish.shen_at_...2...>
Date: Thu, 26 Apr 2007 17:48:53 +0100
Hi,

Which version of Windows are you using? Is it also Windows 2000?

Are you saying you can also load the various libraries individually, etc.?

On Thursday 26 April 2007 17:37, Lutz, Charles D wrote:
> Hi folks,
>  
> FWIW, I have the same problems. I get the same responses if I try
> the command-line commands below.
>  
> This may be an unrelated second problem, but I've noted that .tcl
> scripts are not "tied" to the Tcl interpreter (i.e. in the Start
> menu, under Programs->Tcl, there is e.g. "Widget Tour". The icon
> is the Notepad text file icon. Indeed, if I click it, I get the
> .tcl file open in Notepad vs. running via Wish. I have to start
> Wish as noted previously in this thread and "source" the file
> tkeclipse.tcl.
>  
> Now, when I do that, I do get a small window with the ECLiPSe icon
> in it, with four menus (File, Query, Tools, and Help). In the
> original Tk Console window, I get:
>  
> % Problem loading the ECLiPSe shared libraries: couldn't load
> library ".\tkeclipse.dll": this library or a dependent library
> could not be found in library path
>  
> %
>  
> I also tried the uninstall/reinstall, but unfortunately I am
> not enough of a Tcl expert to diagnose the problem. I hope to
> use the command line version for now, to get started.
>  
> The README:
> http://eclipse.crosscoreop.com/Distribution/5.10_64/i386_nt/Readme.txt
>  
> seems to imply that Tcl/Tk 8.3 is required, therefore I have
> not bothered to try with e.g. ActiveTcl. 
>  

No, you can use Tcl/Tk 8.4. The reason 8.3 is used is because at the time we made
the package, there was no free/open-source binary distribution of Tcl/Tk 8.4 available
for us to include in the ECLiPSe distribution.

Cheers,

Kish

> Thanks,
> Chuck Lutz
>  
> > Kish Shen ha scritto:
> > > If you run this, you should get two windows -- the Tk window, and a
> wish shell.
> > It runs, i also tried to manually load the libraries as suggested by 
> > Joachim, here are the results:
> > 
> > % cd "e:/programmi/eclipse 5.10/lib/i386_nt"
> > % load gmp33.dll
> > couldn't find procedure Gmp_Init
> > % load eclipse.dll
> > couldn't find procedure Eclipse_Init
> > % load tkeclipse.dll
> > couldn't load library "tkeclipse.dll": this library or a dependent 
> > library could not be found in library path
> > %
> > 
> > % cd "e:/programmi/eclipse 5.10/lib/i386_nt"
> > % load tkexdr.dll
> > %
> > 
> > > Also, you could check that the Tcl/Tk dlls are in the right place
> (they should be anyway if you are
> > > able to run wish) -- they are normally installed in C:\Program
> Files\Tcl\bin
> > There are 4 dlls in E:\Programmi\Tcl\bin, anyway, as said, wish runs 
> > correctly.
> > 
> > > I also assume that you have enough disk space to install everything?
> > More than 9 Gbs available.
> > 
> > (Now that i think about it: could it be that there is something 
> > tkeclipse.tcl doesn't like about the fact i have installed the os and 
> > both eclipse and tcl/tk in e:\ instead that in c:\?)
> 
>  
> 
>  
> 
> Chuck Lutz
> 
> Lockheed Martin
> 
> Systems of Systems Engineering
> 
> BMC4I Modeling and Simulation
> 
> Moorestown, NJ
> 
> (856)638-7234 (office)
> 
> charles.d.lutz@...53...
> 
>  
> 
> "A graphic is never an end in itself; it is a moment
> 
> in the process of decision making."
>      - Jacques Bertin
> 
>  
> 
> 
Received on Thu Apr 26 2007 - 17:50:20 CEST

This archive was generated by hypermail 2.2.0 : Mon Jul 09 2018 - 02:05:29 CEST