Recent Changes - Search:

PmWiki

pmwiki.org

edit SideBar

Build

Building core system

Required packages on a Ubuntu Linux:

    gcc
    g++
    libgmp-dev
    tcl8.6-dev     (at least 8.3)
    tk8.6-dev      (at least 8.3)

Building the documentation

Required packages on a Ubuntu Linux. For making pdf manuals:

    texlive-base
    texlive-extra-utils
    texlive-fonts-recommended
    texlive-font-utils
    texlive-latex-base
    texlive-latex-extra
    texlive-latex-recommended
    texlive-pstricks
    texlive-science

For the html versions:

    hevea
    imagemagick

In 2021, there is a hevea/ghostscript incompatibility. Manually edit hevea's /usr/bin/imagen changing

  • ghostscript argument -dSAFER to -dNOSAFER

Also, to be consistent with what we use for pdf, change

  • LATEX=latex to LATEX=pdflatex
Edit - History - Print - Recent Changes - Search
Page last modified on July 04, 2021, at 06:37 PM