[eclipse-clp-users] Tk and Java-embedding problems with v6.1 (dev build 85) on Win7 64

From: -dp- <david_at_...151...>
Date: Fri, 16 Sep 2011 10:44:11 +0800
Thanks for the advice, Kish.

I uninstalled 6.0 and installed this:
http://eclipseclp.org/Distribution/Dev/6.1_85/x86_64_nt/ECLiPSe_6.1_85_x86_64_nt.exe.
But I have problems with both the Tk IDE and with Java embedding...

When I try to launch C:\Program Files\ECLiPSe
6.1\tcltk\x86_64_nt\bin\wish85.exe, I get the two blank windows shown in the
attachment, every time I try launching.

When I try updating my EclipseIDE to run my OutOfProcessEclipse Java
instance using the commandline option below,

-Declipse.directory="C:\Program Files\ECLiPSe 6.1\"


I get an error about not being able to find lib\i386_nt\eclipse.exe. I can't
find anything in my code or settings files that uses that now-obsolete
32-bit path, so I tried providing a more complete path to the 64-bit exe:

-Declipse.directory="C:\Program Files\ECLiPSe 6.1\lib\x86_64_nt"


The path in the error indicates that somewhere, "\lib\i386_nt\eclipse.exe"
is being appended to any path I provide:

java.io.IOException: Cannot run program "C:\Program Files\ECLiPSe
6.1\lib\x86_64_nt\lib\i386_nt\eclipse.exe": CreateProcess error=2, The
system cannot find the file specified
at java.lang.ProcessBuilder.start(ProcessBuilder.java:460)
at java.lang.Runtime.exec(Runtime.java:593)
        [...omitted...]

Might there be some path-completing code that hasn't been updated in both
the Tk code and the Java embedding code, or some local setting I need to
update?

I looked via regedit
at HKEY_LOCAL_MACHINE\SOFTWARE\IC-Parc\ECLiPSe\<version> but didn't see any
mention of i386.

David

btw, there doesn't seem to be any obvious indicator of build number in the
install dir. If you want us to report this when we have problems, please
consider adding something like a 0KB text file named after the build number.



FailedWish85Launch-CLP6.1Win764.png
Received on Fri Sep 16 2011 - 02:44:18 CEST

This archive was generated by hypermail 2.2.0 : Mon Jul 09 2018 - 02:05:29 CEST