Re: [eclipse-clp-users] loading library time_log

From: Kish Shen <kisshen_at_...5...>
Date: Wed, 28 Jul 2010 15:24:11 +0100
Oliver Shycle wrote:
> Hi all,
> 
> I would like to use the time_log library which - according to the ECLiPSe
> Librarys Overview - should exist.
> Unfortunately I cannot load it using the command
> :- lib(time_log).
> 
> I get the error "library not found".
> 
> Is it not further supported and shipped with my ECLiPSe version 6.0?
> 
> Thanks for your help,
> Oliver.
> 

Hi Oliver,

I don't believe lib(time_log) was ever shipped with any ECLiPSe 
distribution. This was (is?) used in the internal testing procedure
of ECLiPSe, to record the run-times for the nightly tests, so that
any sudden big changes in run-time will be noticed. This was done to
catch any unintended performance degradation due to updates to the
system.

I think the main reason it is not generally distributed is because the 
library doesn't seem to be of much use outside of ECLiPSe's testing 
framework. If it is useful, then I don't see why it cannot be 
distributed. What do you want to use the library for?

Where did you find the library mentioned -- was it in the reference manual?

Cheers,

Kish

-- 
This e-mail may contain confidential and privileged material for the
sole use of the intended recipient. Any review, use, distribution or
disclosure by others is strictly prohibited. If you are not the intended
recipient (or authorized to receive for the recipient), please contact
the sender by reply e-mail and delete all copies of this message.
Cisco Systems Limited (Company Number: 02558939), is registered in
England and Wales with its registered office at 1 Callaghan Square,
Cardiff, South Glamorgan CF10 5BT.
Received on Wed Jul 28 2010 - 14:24:20 CEST

This archive was generated by hypermail 2.2.0 : Mon Jul 09 2018 - 02:05:29 CEST