Re: [eclipse-clp-users] eclipse

From: Joachim Schimpf <joachim.schimpf_at_...269...>
Date: Sun, 25 Jul 2010 13:11:38 +1000
paniz alipour wrote:
> why this code has this error?
> 
> model(X):-X :: 0..1 .
> 
> *calling an undefined procedure X :: 0 .. 1 in module eclipse*

ECLiPSe is a rather complex system but comes with a substantial
amount of documentation.  You won't be able to use ECLiPSe
successfully without reading some of it.  Have a look at the
tutorial first http://www.eclipseclp.org/doc/tutorial/tutorial.html,
and some of the examples http://www.eclipseclp.org/examples/index.html

Chapter 8 of the tutorial answers your first question
http://www.eclipseclp.org/doc/tutorial/tutorial053.html


paniz alipour wrote:
> whats the problem of this?????pls help
> 
> model:-NCourse is 20,NRoom is 3,dim(T,[NCourse,NRoom]),
> 
> T[1..NCourse,1..NRoom]:: 0..1.

Nothing wrong with this.


paniz alipour wrote:
> model:-N is 3,dim(T,[N]),T[1..N]::0..1,labeling(T).
>  
> after compile:
> Ambiguous import of :: / 2 from [ic, eplex] in module eclipse
> Ambiguous import of :: / 2 from [ic, eplex] in module eclipse
>  
> after run:
>  
> calling an undefined procedure [](_248, _249, _250)[1 .. 3] :: 0 .. 1 in 
> module eclipse
> what shall I do?!!!!

http://www.eclipseclp.org/doc/tutorial/tutorial033.html#toc39
http://www.eclipseclp.org/doc/userman/umsroot040.html

Do not try to use a combination of ic and eplex until you are
more familiar with the system.


-- Joachim
Received on Sun Jul 25 2010 - 03:11:48 CEST

This archive was generated by hypermail 2.2.0 : Mon Jul 09 2018 - 02:05:29 CEST