Re: [eclipse-clp-users] C++ interface and GCC 4.x

From: Joachim Schimpf <joachim.schimpf_at_...44...>
Date: Wed, 11 Feb 2009 14:22:46 +1100
> Chris Mears wrote:
>> Hello all,
>>
>> The C++ interface doesn't work with recent versions of GCC using the
>> default options.
  ...
>> The proper fix, I think, is to add declarations for functions like
>> newvar, list etc. to Eclipse's C++ header file.  In the meantime, adding
>> -ffriend-injection is a fine workaround.

Done. Build 6.0#73 will have the interface updated for the new scoping rules.

-- Joachim
Received on Wed Feb 11 2009 - 03:22:54 CET

This archive was generated by hypermail 2.2.0 : Mon Jul 09 2018 - 02:05:29 CEST