Re: [eclipse-users] Mac OSX intel install

From: Kish Shen <kish.shen_at_...2...>
Date: Tue, 3 Apr 2007 14:26:03 +0100
Hi Serge,

Thanks for trying this -- as we don't have access to Intel Macs, we need others to try to compile
on the Macs right now, and we would like to get it working...

On Tuesday 03 April 2007 12:14, Serge Kruk wrote:
> I was anxiously awaiting the conclusion of the intel mac experiment  
> that developed last month.
> But the attempts at compiling ECLiPSe for the intel mac seem to have  
> stopped, at least  on this list.
> Maybe I can add a bit of information.
> 
> With the patches_5_10 version
> 
> 1. The --without-gmp still cause a minor problem at link time.  The  
> line 235 of
> Eclipse/sepia/src/Makefile.in
> 		$(RUNPATH_LDFLAG)$(GMP_LIBDIR) \
> causes grief because it expands to
> -L \
> 
> And the linker complains that the switch -L required a directory name.
> (It's easy to delete that line in the Makefile.in but that is not a  
> long term solution).
> 
> 2. At the solver step of make -f Makefile.i386_macosx, I get
> ECLiPSe installation done.
> You should now add /Users/sgkruk/software/Eclipse/bin/i386_macosx
> to your PATH environment variable.
> ======== make_icparc_solvers ========
> make[1]: *** No rule to make target `i386_macosx/edge_finder.dylib',  
> needed by `../lib/i386_macosx/edge_finder.dylib'.  Stop.
> 
I have ran into this problem with fresh builds on some other platforms. The way round it seems
to be create a (in your case) i386_macosx directory in Eclipse/icparc_solver. Try this and let me
know if it gets around the 'No rule to make..' problem

> 
> But since the libraries seem to have been properly created, to wit:
> pwd
> /Users/sgkruk/software/Eclipse/lib/i386_macosx
> 99:~/software/Eclipse/lib/i386_macosx sgkruk$ ls -l
> total 1856
> -rw-r--r--   1 sgkruk  admin    2201 Apr  3 21:03 INST_PARAMS
> -rw-r--r--   1 sgkruk  admin    3800 Apr  3 21:03 Makefile.external
> -rw-r--r--   1 sgkruk  admin     633 Apr  3 21:03 SITE_PARAMS
> -rwxr-xr-x   1 sgkruk  admin   18428 Apr  3 18:13 eclipse.exe
> -rwxrwxrwx   1 sgkruk  admin  860192 Apr  3 18:13 libeclipse.dylib
> -rwxr-xr-x   1 sgkruk  admin    8440 Apr  3 18:13 pteclipse.dylib
> -rwxr-xr-x   1 sgkruk  admin   18868 Apr  3 18:13 tkeclipse.dylib
> -rwxr-xr-x   1 sgkruk  admin   17768 Apr  3 18:13 tkexdr.dylib
> 
> 
> As an additional piece of information, I can try to start eclipse and  
> I get:
> 
> bin/i386_macosx/eclipse
> dyld: Library not loaded: libeclipse.dylib
>    Referenced from: /Users/sgkruk/software/Eclipse/lib/i386_macosx/ 
> eclipse.exe
>    Reason: image not found
> Trace/BPT trap
>
The libeclipse.dylib is in the right place, so it should be found. I don't know if it really can't find
libeclipse.dylib, or if it has problems with some other file libeclipse.dylib depends on [some OS
apparently do not report the problem correctly :-(].

bin/i386_macosx/eclipse is actually a shell script that runs ECLiPSe, can you see what
it actually is?  Here is what the ppc_macosx version that I built a while ago says:

kish@...47...:~/EclipseDevOld/bin/ppc_macosx> more eclipse
#! /bin/sh
ECLIPSEDIR="${ECLIPSEDIR:-/homes/ks15/EclipseDev}"
DYLD_LIBRARY_PATH="$ECLIPSEDIR/lib/ppc_macosx:/homes/ks15/EclipseDev/tcltk/ppc_m
acosx/lib:$DYLD_LIBRARY_PATH"
DYLD_FRAMEWORK_PATH="$TCL_FRAMEWORK:$DYLD_FRAMWORK_PATH"
TCL_LIBRARY="${TCL_LIBRARY:-/homes/ks15/EclipseDev/tcltk/lib/tcl8.4}"
TK_LIBRARY="${TK_LIBRARY:-/homes/ks15/EclipseDev/tcltk/lib/tk8.4}"
DAVINCIHOME="${DAVINCIHOME:-/homes/ks15/EclipseDev/daVinci/ppc_macosx}"
JRE_HOME="${JRE_HOME:-/Library/Java/Home}"
export ECLIPSEDIR TCL_LIBRARY TK_LIBRARY DYLD_FRAMEWORK_PATH DYLD_LIBRARY_PATH D
AVINCIHOME JRE_HOME
exec "/homes/ks15/EclipseDev/lib/ppc_macosx/eclipse.exe" "$@"

===========

In particular, the DYLD_LIBRARY_PATH line should have $ECLIPSEDIR/lib/i386_macosx in
your case...

Cheers,

Kish

> 
> Thanks for any enlightenment you can provide.
> 
> Serge
> 
 
> 
> 
> _______________________________________________
> ECLiPSe-Users mailing list
> ECLiPSe-Users@...2...
> http://www.crosscoreop.com/mailman/listinfo/eclipse-users
> 
Received on Tue Apr 03 2007 - 14:23:08 CEST

This archive was generated by hypermail 2.2.0 : Mon Jul 09 2018 - 02:05:29 CEST