[eclipse-users] Java Interface: java.lang.NoClassDefFoundError

From: Ismael Ojeda <ismaelojeda_at_...32...>
Date: Tue, 6 Mar 2007 17:18:07 -0700
my computer is a AMD semprom 3300+ with  windows XP Home edition, Service pack 2, 

 I just Install JDK 1.6.0 and eclipse 5.10.52,  after compiling,  in ms-dos "cmd" with:

       javac -classpath c:/program files/java/jdk1.6.0/src.zip;c:/program files/eclipsev510/lib/eclipse.jar  quicktest.java

and for running:

        java -Declipse.directory="c:/program files/eclipsev510" 
                -classpath c:/program files/java/jdk1.6.0/src.zip;c:/program files/eclipsev510/eclipse.jar  quicktest

and return:

         Exception in thread "main"  java.lang.NoClassDefFoundError: quicktest

and for running with this change "-D eclipse" :

        java -D eclipse.directory="c:/program files/eclipsev510" 
                -classpath c:/program files/java/jdk1.6.0/src.zip;c:/program files/eclipsev510/eclipse.jar  quicktest

and return:

     Exception in thread "main" java.lang.NoClassDefFoundError:     
     eclipse/director=C:/program files/eclipsev510

so maybe its looking for quicktest.class in folder "C:/program files/eclipsev510 ", and i copy quicktest.class to the folder and even
this ways work...  I reinstall  eclipse... and still returning the same...  

 Mr jacobsen Peder told me that check my eclipse log, i search for a file .log in the folder where I install the eclipse
 and I do not found any file .log      

many thank's 

Ismael Ojeda
DEPI - ITCH
Mexico
Received on Wed Mar 07 2007 - 00:18:22 CET

This archive was generated by hypermail 2.2.0 : Mon Jul 09 2018 - 02:05:29 CEST